Get in touch
Back
Downtime

Outage of Network Remote ID services

Started 13 Sep at 08:00am CEST, resolved 13 Sep at 10:45am CEST.

Main API Live Service API
Resolved

We have restored the functionality of our systems.

Posted 13 Sep at 10:45am CEST.
Created

We're currently facing an outage of our services.

Posted 13 Sep at 08:00am CEST.