Get in touch
Back
Degraded

Detection Duplications for Some RID Receivers

Started 25 Apr at 05:25pm CEST, last updated 26 Apr at 12:59pm CEST.

Live Service API
Updated

All duplications in the detection history have been reconciled, and affected users should now have their detection history fully restored and working properly.

Posted 26 Apr at 12:59pm CEST.
Resolved

The issue was caused by an error in how incoming RID data was assigned, preventing messages from being properly grouped together. As a result, the detection history showed tens or even hundreds of duplicate entries instead of just a few. We recognize that this made the detection data effectively unusable, and we sincerely apologize.

This issue has now been fully resolved for all new detections and should no longer occur. Duplicate entries from before the fix will be cleaned up throughout Saturday, as the correction process requires some time to catch up.

Posted 26 Apr at 01:42am CEST.
Created

We’ve identified an issue affecting some users of our RID receivers, resulting in unusually high amounts of detection duplications. Our investigation indicates that this impacts only users with multiple receivers operating in the same location and detecting the same RID aircraft. We are actively working on a fix and will provide updates as we make progress.

Posted 25 Apr at 05:25pm CEST.