Get in touch
Back
Resolved

Degraded loading performance

Started 12 Nov at 03:51pm CET, resolved 12 Nov at 04:05pm CET.

Airspace Service API
Resolved

Problems has been resolved, operational as usual.

Posted 12 Nov at 04:05pm CET.
Created

We have noticed unusual slowness when loading historical flights on web. Android and iOS apps are not affected. We are working on a solution, in the meantime we recommend refreshing your page in browser to resolve the issues.

Posted 12 Nov at 03:51pm CET.